Forum topics: Previous | Next
Page 1 of 1 (4 items)

Greek subs on VLC

 Hi y'all. My problem is that when I download Greek subtitles and insert into VLC the play in some strange collection of letters - definitley not Greek. How can I alter the settings in VLC to play them as Greek. (I notice that there is a setting called GreekMac but this doesnt work.

Hi I have the same problem but i use KMPlayer.. Did you solve the problem?

Hi, Stella..  try this:

1) You need this soft: Subtitle Edit 2.9.1 (or.. similar)

2) Open the sub with Subtitle Edit, and over the left you'll see ''Subtitle Format'' now, you need to change the file extension from original >(.srt)  to >(.ssa)

3) Go to ''Subtitle Format'' and change: (ANSI - 1252)  to > (UTF-8) ..and (up) change: (SubRip (.srt)) to > (Sub Station Alpha (.ssa))

4) Go to 'File' and 'Save as...'  you'll see the new extension (.ssa) Done!
................................
Note: The new sub format will change the font, and colours font (white - black shadow) but now you'll able to see the special symbols of your own language (hope so) ..it's work for me on my own, Spanish.

Note 2: If you see this symbols <i> and.. </i> on your screen: Open the subs again, and (press CTRL+h), ''Replace''  'Find what' <i>  'Replace with' (nothing.. leave it empty) ..and click 'Replace all' ..Repeat the procedure with </i>  ..Done!

Much MUCH easier:

1. Open the VLC Preferences (CTRL +P)
2. Click on the tab "Subtitles and OSD"
3. Change "Default encoding" to Greek (Windows 1253).
4. Click Save, close VLC and open it again.

Done.

If the characters are still wrong, try other items on the "Default encoding" list. in 98% the one above should be the right one.

 

 

 

Page 1 of 1 (4 items)